Faster Japanese rendering in Firefox

Posted on March 15, 2009. Filed under: Japanese, Linux, openSUSE | Tags: , , , , |

Years before I found that rendering japanese content in Firefox was REALLY slow, but just resigned to live with it and some time later forgot about the whole thing as I stopped accessing japanese content….

Today I found some interesting content again after reading some posts at kirainet.com, and suddenly was annoyed once more with this rendering slowness. After researching a little, I found this post which solves the issue. I’m not pretty sure about why this fonts help to render the pages faster than the stock fonts, should they be included in the distro?

Here’s the procedure to install them in openSUSE (tested with 11.0@x86_64):

Find a suitable repository using http://software.opensuse.org/search

Add the repository to your system (you don’t HAVE TO, but this way you can get updates later):

zypper addrepo http://download.opensuse.org/repositories/home:/swyear/openSUSE_11.0 “Japanese Fonts”

Install the packages:

zypper install ttf-wqy-zenhei wqy-bitmapfont

It will ask if it should trust and later import the key, just answer “YES” to both questions. You’ll have to restart Firefox to use this new fonts..

Pages to test rendering:

http://ja.wikipedia.org/wiki/%E6%97%A5%E6%9C%AC

http://news.google.com/news?ned=cn

http://news.google.com/news?ned=jp

http://kayanomori.net/memo/index.php?iFolder%20Simple%20Server

Advertisements

Make a Comment

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

One Response to “Faster Japanese rendering in Firefox”

RSS Feed for Cyrus doing the blog thing Comments RSS Feed

Following the subject, after installing those fonts some dialog became ugly on openSUSE. Uninstalled them again and installed the following fonts included in the distro:

IPAMincho-002.003-22.1
IPAPMincho-002.003-22.1
IPAGothic-002.003-22.1
IPAPGothic-002.003-22.1
IPAUIGothic-002.003-22.1

The rendering continues to be fast and the dialogs came back to normal look.


Where's The Comment Form?

Liked it here?
Why not try sites on the blogroll...

%d bloggers like this: